<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
<title>Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO)</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/cdn-cgi/apps/head/UcGS1WUTfp_TXEW_EXwpm6SVP_Q.js"></script><link rel="pingback" href="http://www.24wrestling.com/xmlrpc.php" />
<meta property="og:image" content="http://s12660.pcdn.co/wp-content/uploads/2018/11/rusev-lana.jpg" /><link rel="icon" type="image/png" href="http://s12660.pcdn.co/wp-content/uploads/2017/06/favicon.png"><link rel="apple-touch-icon-precomposed" sizes="152x152" href="http://s12660.pcdn.co/wp-content/uploads/2017/06/ios152.png" />

<meta name="news_keywords" content="" />
<link rel="original-source" href="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/" />
<link rel="canonical" href="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO)" />
<meta property="og:description" content="&#8211; Braun Strowman appeared on this week&#8217;s WWE RAW and confronted Paul Heyman to promote the match against WWE Universal Champion Brock Lesnar at the Royal Rumble pay-per-view. As seen in the video above, Strowman was not wearing the sling on his arm, but his elbow was taped up. Strowman underwent a minor elbow operation &hellip;" />
<meta property="og:url" content="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/" />
<meta property="og:site_name" content="24Wrestling" />
<meta property="article:publisher" content="http://www.facebook.com/24wrestling" />
<meta property="article:section" content="WWE News" />
<meta property="article:published_time" content="2018-12-25T17:01:17+00:00" />
<meta property="fb:admins" content="18901620" />
<meta property="og:image" content="http://s12660.pcdn.co/wp-content/uploads/2018/11/rusev-lana.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="675" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="&#8211; Braun Strowman appeared on this week&#8217;s WWE RAW and confronted Paul Heyman to promote the match against WWE Universal Champion Brock Lesnar at the Royal Rumble pay-per-view. As seen in the video above, Strowman was not wearing the sling on his arm, but his elbow was taped up. Strowman underwent a minor elbow operation [&hellip;]" />
<meta name="twitter:title" content="Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO)" />
<meta name="twitter:site" content="@24wrestling" />
<meta name="twitter:image" content="http://s12660.pcdn.co/wp-content/uploads/2018/11/rusev-lana.jpg" />
<meta name="twitter:creator" content="@24wrestling" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.24wrestling.com\/","name":"24Wrestling","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.24wrestling.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="24Wrestling &raquo; Feed" href="http://www.24wrestling.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="24Wrestling &raquo; Comments Feed" href="http://www.24wrestling.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="24Wrestling &raquo; Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO) Comments Feed" href="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/s12660.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.9"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='http://s12660.pcdn.co/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpt-twitter-feed-css' href='http://s12660.pcdn.co/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href="https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.1" type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css' href='http://s12660.pcdn.co/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='http://s12660.pcdn.co/wp-content/themes/Newspaper/style.css?ver=8.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='http://s12660.pcdn.co/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<script type='text/javascript' src='http://s12660.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://s12660.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.24wrestling.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.24wrestling.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://s12660.pcdn.co/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.9" />
<link rel='shortlink' href='https://wp.me/p8PIZ2-n5D' />
<link rel="alternate" type="application/json+oembed" href="http://www.24wrestling.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.24wrestling.com%2Fbraun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.24wrestling.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.24wrestling.com%2Fbraun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://s12660.pcdn.co/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="amphtml" href="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/amp/" />

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_ajax_url="http:\/\/www.24wrestling.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.1";
var td_get_template_directory_uri="http:\/\/www.24wrestling.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="7";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="3";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#dd3333";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2618320-6', 'auto');
  ga('send', 'pageview');

</script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "http://www.24wrestling.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.24wrestling.com/category/news/",
                                "name": "Wrestling News"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/",
                                "name": "Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa..."                                
                            }
                        }    ]
                        }
                       </script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-88761 single-format-standard global-block-template-1 white-menu wpb-js-composer js-comp-ver-5.1.1 vc_responsive td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-26472" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-26472"><a title="Wrestling News" href="http://www.24wrestling.com/">Home</a></li>
<li id="menu-item-78220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78220"><a href="https://www.facebook.com/24wrestling/">24W on Facebook</a></li>
<li id="menu-item-78221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78221"><a href="https://www.twitter.com/24wrestling">24W on Twitter</a></li>
<li id="menu-item-47415" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-47415"><a title="MMA News" href="http://www.mmanews.com">MMA News</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.24wrestling.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">

<div class="td-header-wrap td-header-style-7">
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient">
<div class="td-container td-header-row td-header-main-menu">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="http://www.24wrestling.com/">
<img src="http://s12660.pcdn.co/wp-content/uploads/2017/06/logo.png" alt="" />
<span class="td-visual-hidden">24Wrestling</span>
</a>
</div>
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-disable" href="http://www.24wrestling.com/">
<img src="http://s12660.pcdn.co/wp-content/uploads/2017/06/logo.png" alt="" />
</a>
<a class="td-header-logo td-sticky-disable" href="http://www.24wrestling.com/">
<img src="http://s12660.pcdn.co/wp-content/uploads/2017/06/logo.png" alt="" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-26472"><a title="Wrestling News" href="http://www.24wrestling.com/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-78220"><a href="https://www.facebook.com/24wrestling/">24W on Facebook</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-78221"><a href="https://www.twitter.com/24wrestling">24W on Twitter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-47415"><a title="MMA News" href="http://www.mmanews.com">MMA News</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div class="header-search-wrap">
<div class="dropdown header-search">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="http://www.24wrestling.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div> </div>
</div>
</div>
<div class="td-banner-wrap-full td-container-wrap ">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
</div>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/2322101/24w', [1, 1], 'div-gpt-ad-1506183003369-0').addService(googletag.pubads());
    googletag.defineSlot('/2322101/24W-Billboard', [[728, 90], [970, 250]], 'div-gpt-ad-1506183003369-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script src="//tags-cdn.deployads.com/a/24wrestling.com.js" async></script> </div>
</div>
</div>
</div><div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="http://www.24wrestling.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Wrestling News" class="entry-crumb" href="http://www.24wrestling.com/category/news/">Wrestling News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa...</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<article id="post-88761" class="post-88761 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-wwe" itemscope itemtype="http://schema.org/Article">
<div class="td-post-header">
<header class="td-post-title">
<h1 class="entry-title">Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO)</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="http://www.24wrestling.com/author/scottlaz/">24W Staff</a><div class="td-author-line"> - </div> </div> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2018-12-25T17:01:17+00:00">December 25, 2018</time></span> </div>
</header>
</div>
<div class="td-post-content">
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/BsyY92iAhSU" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>&#8211; Braun Strowman appeared on this week&#8217;s WWE RAW and confronted Paul Heyman to promote the match against WWE Universal Champion Brock Lesnar at the Royal Rumble pay-per-view. As seen in the video above, Strowman was not wearing the sling on his arm, but his elbow was taped up. Strowman underwent a minor elbow operation last month. The segment was taped last Monday night, just one night after Strowman appeared with the sling at the WWE TLC pay-per-view. The Monster Among Men noted on RAW that he will be cleared in time to face The Beast at the Rumble. As we&#8217;ve noted, Strowman is not expected to wrestle before the Rumble.</p>
<p>&#8211; Rusev turns 33 years old today while former TNA Knockout Rhaka Khan (Trenesha Biggers) turns 37 and former WWE &#038; TNA star Chris Harris (Braden Walker) turns 45. Rusev will challenge WWE United States Champion Shinsuke Nakamura on tonight&#8217;s Christmas Night edition of SmackDown.</p>
<p>&#8211; This week&#8217;s Christmas Eve edition of RAW saw Rhyno make his return as Santa Claus. The return came during Heath Slater vs. Jinder Mahal, which ended in a DQ as The Singh Brothers attacked Slater during a pin attempt. Slater went for the pin as Jinder was distracted by Santa in the crowd. Santa entered the ring and ended up attacking Jinder, then helping Slater clear the ring of The Singh Brothers. Santa then delivered a Gore to Jinder and revealed himself to be The Man Beast.</p>
<p>This could be Rhyno&#8217;s return to the storylines as himself. He was recently &#8220;fired&#8221; by then-General Manager Baron Corbin, who also demoted Slater to the job of a referee. Corbin lost his powers at the TLC pay-per-view and Slater quit as a referee. This week&#8217;s RAW saw Slater reveal his Christmas wish earlier in the show &#8211; that his buddy Rhyno could get his job back as a Superstar. Below are a few shots from Rhyno&#8217;s return on RAW:</p>
<blockquote class="twitter-tweet" data-lang="en">
<p lang="en" dir="ltr">RIGHT NOW: <a href="https://twitter.com/JinderMahal?ref_src=twsrc%5Etfw">@JinderMahal</a> vs. <a href="https://twitter.com/HeathSlaterOMRB?ref_src=twsrc%5Etfw">@HeathSlaterOMRB</a> in one-on-one action on <a href="https://twitter.com/hashtag/RAWChristmas?src=hash&amp;ref_src=twsrc%5Etfw">#RAWChristmas</a>! <a href="https://twitter.com/hashtag/RAW?src=hash&amp;ref_src=twsrc%5Etfw">#RAW</a> <a href="https://t.co/ofm2I4905K">pic.twitter.com/ofm2I4905K</a></p>
<p>&mdash; WWE (@WWE) <a href="https://twitter.com/WWE/status/1077405482841604096?ref_src=twsrc%5Etfw">December 25, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<blockquote class="twitter-tweet" data-lang="en">
<p lang="en" dir="ltr">It&#39;s RHYNO CLAUS! 🎅🎅🎅<a href="https://twitter.com/Rhyno313?ref_src=twsrc%5Etfw">@Rhyno313</a> is BACK!!!!! <a href="https://twitter.com/hashtag/RAW?src=hash&amp;ref_src=twsrc%5Etfw">#RAW</a> <a href="https://twitter.com/hashtag/RAWChristmas?src=hash&amp;ref_src=twsrc%5Etfw">#RAWChristmas</a> <a href="https://twitter.com/HeathSlaterOMRB?ref_src=twsrc%5Etfw">@HeathSlaterOMRB</a> <a href="https://t.co/ihMRxywKjw">pic.twitter.com/ihMRxywKjw</a></p>
<p>&mdash; WWE (@WWE) <a href="https://twitter.com/WWE/status/1077406085810536448?ref_src=twsrc%5Etfw">December 25, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/6xNrTysZcf8" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
</div>
<footer>
<div class="td-post-source-tags">
</div>
<div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://www.24wrestling.com/author/scottlaz/">24W Staff</a></span></div> <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="24W Staff"></span><meta itemprop="datePublished" content="2018-12-25T17:01:17+00:00"><meta itemprop="dateModified" content="2018-12-25T17:01:17+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.24wrestling.com/braun-strowman-injury-update-rusev-day-today-rhyno-returns-santa-claus-video/" /><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://s12660.pcdn.co/wp-content/uploads/2017/06/logo.png"></span><meta itemprop="name" content="24Wrestling"></span><meta itemprop="headline " content="Braun Strowman Injury Update, Rusev Day Is Today, Rhyno Returns As Santa Claus (VIDEO)"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://s12660.pcdn.co/wp-content/uploads/2018/11/rusev-lana.jpg"><meta itemprop="width" content="1200"><meta itemprop="height" content="675"></span> </footer>
</article> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<div class="td_block_wrap td_block_21 td_block_widget td_uid_3_5c23132eec7fb_rand td-pb-border-top td_block_template_1 td-column-1" data-td-block-uid="td_uid_3_5c23132eec7fb">
<style>
body .td_uid_3_5c23132eec7fb_rand .td_module_wrap:hover .entry-title a,
            body .td_uid_3_5c23132eec7fb_rand .td-pulldown-filter-link:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-subcat-item a:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-subcat-item .td-cur-simple-item,
            body .td_uid_3_5c23132eec7fb_rand .td_quote_on_blocks,
            body .td_uid_3_5c23132eec7fb_rand .td-opacity-cat .td-post-category:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-opacity-read .td-read-more a:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-opacity-author .td-post-author-name a:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-instagram-user a {
                color: #242424;
            }

            body .td_uid_3_5c23132eec7fb_rand .td-next-prev-wrap a:hover,
            body .td_uid_3_5c23132eec7fb_rand .td-load-more-wrap a:hover {
                background-color: #242424;
                border-color: #242424;
            }

            body .td_uid_3_5c23132eec7fb_rand .block-title > *,
            body .td_uid_3_5c23132eec7fb_rand .td-trending-now-title,
            body .td_uid_3_5c23132eec7fb_rand .td-read-more a,
            body .td_uid_3_5c23132eec7fb_rand .td-weather-information:before,
            body .td_uid_3_5c23132eec7fb_rand .td-weather-week:before,
            body .td_uid_3_5c23132eec7fb_rand .td-subcat-dropdown:hover .td-subcat-more,
            body .td_uid_3_5c23132eec7fb_rand .td-exchange-header:before,
            body .td-footer-wrapper .td_uid_3_5c23132eec7fb_rand .td-post-category,
            body .td_uid_3_5c23132eec7fb_rand .td-post-category:hover {
                background-color: #242424;
            }
            body .td-footer-wrapper .td_uid_3_5c23132eec7fb_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            body .td_uid_3_5c23132eec7fb_rand .block-title {
                border-color: #242424;
            }
</style><script>var block_td_uid_3_5c23132eec7fb = new tdBlock();
block_td_uid_3_5c23132eec7fb.id = "td_uid_3_5c23132eec7fb";
block_td_uid_3_5c23132eec7fb.atts = '{"limit":"4","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Latest News","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#242424","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_3_5c23132eec7fb_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5c23132eec7fb_rand","tdc_css_class_style":"td_uid_3_5c23132eec7fb_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_3_5c23132eec7fb.td_column_number = "1";
block_td_uid_3_5c23132eec7fb.block_type = "td_block_21";
block_td_uid_3_5c23132eec7fb.post_count = "4";
block_td_uid_3_5c23132eec7fb.found_posts = "35412";
block_td_uid_3_5c23132eec7fb.header_color = "#242424";
block_td_uid_3_5c23132eec7fb.ajax_pagination_infinite_stop = "";
block_td_uid_3_5c23132eec7fb.max_num_pages = "8853";
tdBlocksArray.push(block_td_uid_3_5c23132eec7fb);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">Latest News</span></h4></div><div id=td_uid_3_5c23132eec7fb class="td_block_inner">
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/vince-mcmahon-aj-styles-assault-wwe-edits-segment-new-storyline-begins-videos-photo/" rel="bookmark" title="Vince McMahon &#038; AJ Styles Assault Each Other, WWE Edits Segment, New Storyline Begins? (VIDEOS &#038; PHOTO)"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-styles-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-styles-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-styles-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="Vince McMahon &#038; AJ Styles Assault Each Other, WWE Edits Segment, New Storyline Begins? (VIDEOS &#038; PHOTO)" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/vince-mcmahon-aj-styles-assault-wwe-edits-segment-new-storyline-begins-videos-photo/" rel="bookmark" title="Vince McMahon &#038; AJ Styles Assault Each Other, WWE Edits Segment, New Storyline Begins? (VIDEOS &#038; PHOTO)">Vince McMahon &#038; AJ Styles Assault Each Other, WWE Edits Segment, New Storyline Begins?...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-26T04:12:05+00:00">December 26, 2018</time></span> </div>
<div class="td-excerpt">
[youtube https://www.youtube.com/watch?v=IrTFJsEVYEs&amp;w=560&amp;h=315]
Tonight&#039;s Christmas edition of WWE SmackDown closed with a very interesting exchange between Vince McMahon and AJ Styles. You can see video of... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/photos-videos-rusev-captures-wwe-us-title-rusev-day/" rel="bookmark" title="PHOTOS &#038; VIDEOS: Rusev Captures WWE US Title On Rusev Day"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/rusev-24-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/rusev-24-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/rusev-24-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="PHOTOS &#038; VIDEOS: Rusev Captures WWE US Title On Rusev Day" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/photos-videos-rusev-captures-wwe-us-title-rusev-day/" rel="bookmark" title="PHOTOS &#038; VIDEOS: Rusev Captures WWE US Title On Rusev Day">PHOTOS &#038; VIDEOS: Rusev Captures WWE US Title On Rusev Day</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-26T03:08:04+00:00">December 26, 2018</time></span> </div>
<div class="td-excerpt">
Rusev defeated Shinsuke Nakamura to capture the WWE United States Title on tonight&#039;s Christmas edition of SmackDown.
The match was taped last Tuesday night at... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/john-cena-done-talking-nikki-bella/" rel="bookmark" title="John Cena Is Done Talking About Nikki Bella"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2015/08/john-cena-nikki-bella-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2015/08/john-cena-nikki-bella-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2015/08/john-cena-nikki-bella-50x50.jpg 50w, http://s12660.pcdn.co/wp-content/uploads/2015/08/john-cena-nikki-bella-266x266.jpg 266w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="John Cena Is Done Talking About Nikki Bella" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/john-cena-done-talking-nikki-bella/" rel="bookmark" title="John Cena Is Done Talking About Nikki Bella">John Cena Is Done Talking About Nikki Bella</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-26T01:40:06+00:00">December 26, 2018</time></span> </div>
<div class="td-excerpt">
John Cena is done talking about ex-fiancee Nikki Bella.
We&#039;ve noted how Cena appeared at the Empire State Building in New York City on Thursday... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/live-wwe-smackdown-results-videos-fresno-12-25-2018/" rel="bookmark" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/live-wwe-smackdown-results-videos-fresno-12-25-2018/" rel="bookmark" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018">Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-26T00:48:57+00:00">December 26, 2018</time></span> </div>
<div class="td-excerpt">
[youtube https://www.youtube.com/watch?v=E5quLUhFhUg&amp;w=560&amp;h=315]
- Tonight&#039;s Christmas edition of WWE SmackDown opens up live on a tape delay from the Save Mart Center in Fresno, California. The... </div>
</div>
</div>
</div></div> <div class="td_block_wrap td_block_21 td_block_widget td_uid_5_5c23132f0aea7_rand td-pb-border-top td_block_template_1 td-column-1" data-td-block-uid="td_uid_5_5c23132f0aea7">
<style>
body .td_uid_5_5c23132f0aea7_rand .td_module_wrap:hover .entry-title a,
            body .td_uid_5_5c23132f0aea7_rand .td-pulldown-filter-link:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-subcat-item a:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-subcat-item .td-cur-simple-item,
            body .td_uid_5_5c23132f0aea7_rand .td_quote_on_blocks,
            body .td_uid_5_5c23132f0aea7_rand .td-opacity-cat .td-post-category:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-opacity-read .td-read-more a:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-opacity-author .td-post-author-name a:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-instagram-user a {
                color: #242424;
            }

            body .td_uid_5_5c23132f0aea7_rand .td-next-prev-wrap a:hover,
            body .td_uid_5_5c23132f0aea7_rand .td-load-more-wrap a:hover {
                background-color: #242424;
                border-color: #242424;
            }

            body .td_uid_5_5c23132f0aea7_rand .block-title > *,
            body .td_uid_5_5c23132f0aea7_rand .td-trending-now-title,
            body .td_uid_5_5c23132f0aea7_rand .td-read-more a,
            body .td_uid_5_5c23132f0aea7_rand .td-weather-information:before,
            body .td_uid_5_5c23132f0aea7_rand .td-weather-week:before,
            body .td_uid_5_5c23132f0aea7_rand .td-subcat-dropdown:hover .td-subcat-more,
            body .td_uid_5_5c23132f0aea7_rand .td-exchange-header:before,
            body .td-footer-wrapper .td_uid_5_5c23132f0aea7_rand .td-post-category,
            body .td_uid_5_5c23132f0aea7_rand .td-post-category:hover {
                background-color: #242424;
            }
            body .td-footer-wrapper .td_uid_5_5c23132f0aea7_rand .block-title > * {
                padding: 6px 7px 5px;
                line-height: 1;
            }

            body .td_uid_5_5c23132f0aea7_rand .block-title {
                border-color: #242424;
            }
</style><script>var block_td_uid_5_5c23132f0aea7 = new tdBlock();
block_td_uid_5_5c23132f0aea7.id = "td_uid_5_5c23132f0aea7";
block_td_uid_5_5c23132f0aea7.atts = '{"limit":"5","sort":"jetpack_popular_2","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"","category_ids":"","custom_title":"Trending Articles","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#242424","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_5_5c23132f0aea7_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_5_5c23132f0aea7_rand","tdc_css_class_style":"td_uid_5_5c23132f0aea7_rand_style","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_5_5c23132f0aea7.td_column_number = "1";
block_td_uid_5_5c23132f0aea7.block_type = "td_block_21";
block_td_uid_5_5c23132f0aea7.post_count = "5";
block_td_uid_5_5c23132f0aea7.found_posts = "8";
block_td_uid_5_5c23132f0aea7.header_color = "#242424";
block_td_uid_5_5c23132f0aea7.ajax_pagination_infinite_stop = "";
block_td_uid_5_5c23132f0aea7.max_num_pages = "2";
tdBlocksArray.push(block_td_uid_5_5c23132f0aea7);
</script><div class="td-block-title-wrap"><h4 class="block-title"><span class="td-pulldown-size">Trending Articles</span></h4></div><div id=td_uid_5_5c23132f0aea7 class="td_block_inner">
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/live-wwe-raw-results-videos-12-24-2018/" rel="bookmark" title="Full WWE RAW Results &#038; Videos, 12/24/2018"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/raw-24-1-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/raw-24-1-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/raw-24-1-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="Full WWE RAW Results &#038; Videos, 12/24/2018" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/live-wwe-raw-results-videos-12-24-2018/" rel="bookmark" title="Full WWE RAW Results &#038; Videos, 12/24/2018">Full WWE RAW Results &#038; Videos, 12/24/2018</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-24T23:43:24+00:00">December 24, 2018</time></span> </div>
<div class="td-excerpt">
[youtube https://www.youtube.com/watch?v=W-22Q6WmTH8&amp;w=560&amp;h=315]
- Tonight&#039;s Christmas Eve edition of WWE RAW opens live on a tape delay with a &quot;Twas The RAW Before Christmas&quot; video to... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/video-vince-mcmahon-makes-huge-wwe-announcements-raw-new-titles-john-cena-cage-match/" rel="bookmark" title="VIDEO: Vince McMahon Makes Huge WWE Announcements On RAW &#8211; New Titles, John Cena, Cage Match"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-santa-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-santa-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/vince-santa-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="VIDEO: Vince McMahon Makes Huge WWE Announcements On RAW &#8211; New Titles, John Cena, Cage Match" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/video-vince-mcmahon-makes-huge-wwe-announcements-raw-new-titles-john-cena-cage-match/" rel="bookmark" title="VIDEO: Vince McMahon Makes Huge WWE Announcements On RAW &#8211; New Titles, John Cena, Cage Match">VIDEO: Vince McMahon Makes Huge WWE Announcements On RAW &#8211; New Titles, John Cena,...</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-25T02:38:53+00:00">December 25, 2018</time></span> </div>
<div class="td-excerpt">
Vince McMahon appeared on tonight&#039;s Christmas Eve edition of WWE RAW and made three big announcements as Santa Claus, or Mr. McMahon-ta Claus.
Vince revealed... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/wwe-stars-react-vince-mcmahons-announcement-womens-tag-team-titles/" rel="bookmark" title="WWE Stars React To Vince McMahon&#8217;s Announcement On Women&#8217;s Tag Team Titles"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/sonya-deville-mandy-rose-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/sonya-deville-mandy-rose-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/sonya-deville-mandy-rose-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="WWE Stars React To Vince McMahon&#8217;s Announcement On Women&#8217;s Tag Team Titles" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/wwe-stars-react-vince-mcmahons-announcement-womens-tag-team-titles/" rel="bookmark" title="WWE Stars React To Vince McMahon&#8217;s Announcement On Women&#8217;s Tag Team Titles">WWE Stars React To Vince McMahon&#8217;s Announcement On Women&#8217;s Tag Team Titles</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-25T18:13:31+00:00">December 25, 2018</time></span> </div>
<div class="td-excerpt">
As noted, Vince McMahon appeared on last night&#039;s WWE RAW and confirmed that new WWE Women&#039;s Tag Team Titles will be revealed in 2019.
Below... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/seth-rollins-praises-baron-corbin-mens-royal-rumble-match-update-tonights-wwe-smackdown/" rel="bookmark" title="Seth Rollins Praises Baron Corbin, Men&#8217;s Royal Rumble Match Update, Tonight&#8217;s WWE SmackDown"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2017/06/seth-rollins-2-120x120.jpg" alt="" title="Seth Rollins Praises Baron Corbin, Men&#8217;s Royal Rumble Match Update, Tonight&#8217;s WWE SmackDown" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/seth-rollins-praises-baron-corbin-mens-royal-rumble-match-update-tonights-wwe-smackdown/" rel="bookmark" title="Seth Rollins Praises Baron Corbin, Men&#8217;s Royal Rumble Match Update, Tonight&#8217;s WWE SmackDown">Seth Rollins Praises Baron Corbin, Men&#8217;s Royal Rumble Match Update, Tonight&#8217;s WWE SmackDown</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-25T17:04:11+00:00">December 25, 2018</time></span> </div>
<div class="td-excerpt">
Below is the non-spoiler match listing for tonight&#039;s Christmas Night edition of WWE SmackDown, taped last week in Fresno, CA. We have a... </div>
</div>
</div>
<div class="td_module_16 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="http://www.24wrestling.com/live-wwe-smackdown-results-videos-fresno-12-25-2018/" rel="bookmark" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018"><img width="120" height="120" class="entry-thumb" src="http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-120x120.jpg" srcset="http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-120x120.jpg 120w, http://s12660.pcdn.co/wp-content/uploads/2018/12/sd-2-150x150.jpg 150w" sizes="(max-width: 120px) 100vw, 120px" alt="" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="http://www.24wrestling.com/live-wwe-smackdown-results-videos-fresno-12-25-2018/" rel="bookmark" title="Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018">Full WWE SmackDown Results &#038; Videos From Fresno, 12/25/2018</a></h3>
<div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-26T00:48:57+00:00">December 26, 2018</time></span> </div>
<div class="td-excerpt">
[youtube https://www.youtube.com/watch?v=E5quLUhFhUg&amp;w=560&amp;h=315]
- Tonight&#039;s Christmas edition of WWE SmackDown opens up live on a tape delay from the Save Mart Center in Fresno, California. The... </div>
</div>
</div>
</div></div> <div class="td-a-rec td-a-rec-id-custom_ad_1  td-rec-hide-on-p td_uid_6_5c23132f0e676_rand td_block_template_1"><div class="ad-tag" data-ad-name="Sortable 300x250 Below The Fold Desktop" data-ad-size="300x250"></div>
<script src="//tags-cdn.deployads.com/a/24wrestling.com.js" async></script>
<script>(deployads = window.deployads || []).push({});</script></div><aside class="td_block_template_1 widget widget_text"> <div class="textwidget"><p><center><a href="https://sports.betway.com/en/sports/" alt="Betway sport betting site banner large sq"><img border="0" src="http://s12660.pcdn.co/wp-content/uploads/2018/05/Betway-sports-betting-site-336x280.jpg" alt="Betway sport betting site banner large sq"></a></center></p>
</div>
</aside> </div>
</div>
</div> 
</div> 
</div> 


<div class="td-footer-wrapper td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-bottom-menu-container"><ul id="menu-bottom-menu" class="td-subfooter-menu"><li id="menu-item-31389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-31389"><a href="http://www.24wrestling.com/contact/">Contact Us</a></li>
<li id="menu-item-31387" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31387"><a href="http://www.24wrestling.com/terms-of-use/">Terms Of Use</a></li>
<li id="menu-item-31388" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31388"><a href="http://www.24wrestling.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
</div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
/* Center the damn tweets */
.twitter-tweet {
    margin: 0 auto ;
}


/* Center the damn instas */
.instagram-media  {
    margin: 0 auto ;
}
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.24wrestling.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://s12660.pcdn.co/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201852'></script>
<script type='text/javascript' src='http://s12660.pcdn.co/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.1'></script>
<script type='text/javascript' src='http://s12660.pcdn.co/wp-includes/js/comment-reply.min.js?ver=4.9.9'></script>
<script type='text/javascript' src='http://s12660.pcdn.co/wp-includes/js/wp-embed.min.js?ver=4.9.9'></script>

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[88761]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://s12660.pcdn.co/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://s12660.pcdn.co/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>

<style>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</style>
<script type='text/javascript' src='https://stats.wp.com/e-201852.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'130538336',post:'88761',tz:'0',srv:'www.24wrestling.com'} ]);
	_stq.push([ 'clickTrackerInit', '130538336', '88761' ]);
</script>
</body>
</html>